Discussion:
filters/resize: Upgrade to a newer libavutil API
(too old to reply)
Henrik Gramner
2017-12-25 19:40:08 UTC
Permalink
x264 | branch: master | Henrik Gramner <***@gramner.com> | Sun Oct 22 10:50:46 2017 +0200| [1221f097473a049a52fbb47aff2733321bd4661a] | committer: Anton Mitrofanov

filters/resize: Upgrade to a newer libavutil API

Use the AVComponentDescriptor depth field instead of depth_minus1.
http://git.videolan.org/gitweb.cgi/x264.git/?a=commit;h=1221f097473a049a52fbb47aff2733321bd4661a
---

filters/video/resize.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/filters/video/resize.c b/filters/video/resize.c
index 95c8ec88..3ec224eb 100644
--- a/filters/video/resize.c
+++ b/filters/video/resize.c
@@ -212,7 +212,7 @@ static int pick_closest_supported_csp( int csp )
}
// now determine high depth
for( int i = 0; i < pix_desc->nb_components; i++ )
- if( pix_desc->comp[i].depth_minus1 >= 8 )
+ if( pix_desc->comp[i].depth > 8 )
ret |= X264_CSP_HIGH_DEPTH;
return ret;
}

Loading...